{
    "mode": "man",
    "parameter": "scsi-config",
    "section": "8",
    "url": "https://www.chedong.com/phpMan.php/man/scsi-config/8/json",
    "generated": "2026-10-04T15:16:56Z",
    "synopsis": "scsi-config [device]",
    "sections": {
        "NAME": {
            "content": "scsi-config - query information from a scsi device with a nice user interface\n",
            "subsections": []
        },
        "SYNOPSIS": {
            "content": "scsi-config [device]\n",
            "subsections": []
        },
        "DESCRIPTION": {
            "content": "scsi-config queries information from an scsi target with a nice Tcl/Tk user interface. If you\ndo  not  specify  a  device  to query, scsi-config calculates a list of available devices and\nprompts it to you.\n\nBy the nature of a graphical user interface, most things will explain them  self.  Basically,\nscsi-config shows a list of buttons for certain mode pages which you may press. Those buttons\nwhich  you  can  press and the text windows with white backgrounds can be modified by you and\nthe modifications send back to the device.\n\nIn the main window there is a button to instruct the device to save  the  data  in  some  non\nvolatile  memory  (if  it  supports  it). Note that this will instruct the device to save the",
            "subsections": [
                {
                    "name": "Read-Write Error Recovery Page , Disconnect-Reconnect Page , Format  Device  Page  ,  Caching",
                    "content": ""
                },
                {
                    "name": "Page , and Control Mode Page in its NVRAM. Usually saving even a single of those should write",
                    "content": "them all to the NVRAM, but you never know.\n\nYou  can query the current, the factory default and the values in the NVRAM (which may not be\nthe current parameters) from the device.\n\nNot all combinations of button toggles or all values are valid. In general, try to  set  them\nand see which values the drive accepts.  scsi-config rereads the device configuration immedi‐\nately, s.t. you see which values where accepted.\n\nAlso  note  that  some disk drives are notched, and that those have an active notch (shown in\nthe main window) to which all your settings apply (at least those of notched pages, which are\nalso marked in slate gray). You can select the active notch to which your settings apply (and\nto which the values refer) in the Notch Page.\n\nFor those devices which do not feature an NVRAM (generally removable media devices) and as  a\nkind  of  backup,  you  can  save the current settings to a file. Actually the file will be a\n/bin/sh script making the necessary scsiinfo(8) calls to set the saved parameters  when  exe‐\ncuted.\n\nThere  is  also  a nice Overview button which will query many details about the disk geometry\nand draw them in a nice picture. This looks esp. nice for drives with many notches,  that  is\ndifferent regions on the disk with different tracks per sector settings. It is also very use‐\nful for notched drives as you can immediately select the mode pages for each notch.\n\n"
                }
            ]
        },
        "SOME USAGE GUIDELINES": {
            "content": "",
            "subsections": [
                {
                    "name": "1. General Warning",
                    "content": "Generally, do not modify settings you don't understand. It is useful to know the SCSI-\nII  specs  mentioned below. Some setting may render the device unusable or even damage\nit. Usually a power cycle resets the state (if you do not save the weird  settings  in\nthe  NVRAM). Some settings affecting the assignment of logical sectors will render the\ndisk unusable until the next low level format.\n"
                },
                {
                    "name": "2. On Write Caching",
                    "content": "As an old warning, this does also mean you should not generally switch the write cache\non.  At least on those drives where you have a choice at all. Reasons are twofold:\n\na)     It is a priori unclear when the drive will actually perform the writes. This is\na bad thing when considering shutdown of your machine. On the  other  hand,  it\nseems  sensible  to  assume that the drive will immediately write it's cache to\ndisk when it is idle (after all file systems are unmounted) and due to the size\nof the on disk cache this will usually only need a few seconds after the  shut‐\ndown  (but  the  drive lamp will usually not glow, as it is mostly connected to\nthe host adapter (if you have a lamp at all) and it is not participating).\n\nThere is a SCSI command to flush the caches. Linux could call it prior to shut‐\nting down, spinning a disk down. Due to my  knowledge  this  is  not  yet  done\nthough.\n\nb)     As the writes are performed asynchronously, errors are reported asynchronously.\nThe  disk  might  return  an error at some simple read instruction related to a\nwrite which was acknowledged OK several transactions ago. This  generally  con‐\nfuses  things  and  makes  interpreting errors very difficult. Some devices are\nknown/said to not report write errors in this mode of operation at all.\n\nJust imagine that at the point where a file system is unmounted, or a  new  re‐\nmovable  media is detected it could tell: Oops, BTW, there was some write error\nago although I told you it was OK already.\n\n\nThus, when you run a disk in write cache mode, keep it in mind when weird  error  mes‐\nsages  occur  and  give  the disk time to flush it's buffers at shutdown. Generally it\nwould be good if you knew more vendor specific details on how the disk operates in the\nwrite cache mode.\n\n"
                },
                {
                    "name": "3. Reassigning Bad Blocks Automatically",
                    "content": "One of the nice features of SCSI disk is that they allow to remap bad blocks automati‐\ncally as they are detected without any user intervention. However, you  actually  have\nto  enable  this  feature!   It turned out that you can not generally assume a disk in\nthis mode. To enable this mode or check the settings, proceed as follows:\n\na)     Go to the Read-Write Error Recovery Page.  AWRE (Automatic  Write  Reallocation\nEnable)  and ARRE (Automatic Read Reallocation Enable) buttons enable the auto‐\nmatic reallocation.\n\nIn the same window, you can select the maximal retries  performed.  EER  allows\nthe  disk to do some Early Error Recovery which is fast (but might misdetect or\nmiscorrect data).  A selected DCR button (Disable CoRrection  Codes)  disallows\nthe  disk to use any error correction codes at all (thus the drive will have to\nretry until it performs an error free read).\n\nUsually a sector will be reallocated after even a  single  read  retry  or  the\ngiven  number  of failed write retries. When the sector cannot be recovered, it\nis reallocated but the data is lost and an error is signalled.\n\nThe other buttons there apply to error reporting as well. TB Transmits the  bad\nBlock  together  with the error, RC Reads Continuous, that is, does not pause a\nread operation while retrying or using error code calculations to recover a bad\nblock (thus may return bad data). PER lets the disk report even  recovered  er‐\nrors  (Post  ERror), DTE (Disable Transfer on Error) even breaks a running data\ntransmission when an error is detected.\n\n\nb)     Even when the reallocation is enabled, the disk must  actually  have  some  re‐\nserved  areas where to remap the bad blocks. The Format Page controls this. Ei‐\nther a given number of Alternate Sectors Per LUN is set  aside  for  the  whole\ndisk  or  a  given number of tracks is defined to be a zone and for each zone a\nnumber of sectors or tracks is put aside.  These alternate data areas are where\nbad sectors are remapped.\n\nNote that this page is very likely to apply only to  the  current  notch  on  a\nnotched disk device.\n\nIf  there are no, or not many alternate sectors reserved on your disk, you must\nchange these settings.\n\nI found that those disks which allow to modify these settings  are  very  often\nset  to  no reserved sectors at all by the vendors, as this increases the disks\ncapacity. For the sake of stability, you should really modify these settings.\n\nIf you decide to modify the number of alternate sectors, you must\n\ni)     Save the parameters to the NVRAM of the disk.\n\nii)    Low-level format the disk drive (and not erase the NVRAM during this op‐\neration).\n\nto make the changes be effective.\n\n\nc)     Esp. when you set the disk to not report recovered errors (or when it is  in  a\nwrite cache mode or something), and just as a general guideline, keep an eye on\nthe grown defects list where the disk will report all the remappings which took\nplace as your disk ages.\n\nThe  old adventurers guide line applies: Save (Backup) Early, Save (Backup) Of‐\nten. Find the right time to replace your disk avoiding too much work recovering\nyour data.\n\n"
                }
            ]
        },
        "BUGS": {
            "content": "scsi-config could be enhanced by making better use of Tcl/Tk. I learned much about it  during\nmy  work  on  tkscsiformat(8)  and their would be much room for fixes and enhances. On other\nhand, it fulfils it's purpose as it is quite nicely already.\n\nAs scsi-config makes heavy use of scsiinfo(8) all it's bugs (esp. on defect reading) apply.\n\n",
            "subsections": []
        },
        "FILES": {
            "content": "/usr/lib/scsi/cache,  /usr/lib/scsi/control,  /usr/lib/scsi/disconnect,  /usr/lib/scsi/error,\n/usr/lib/scsi/format,   /usr/lib/scsi/generic,   /usr/lib/scsi/inquiry,  /usr/lib/scsi/notch,\n/usr/lib/scsi/overview,  /usr/lib/scsi/peripheral,  /usr/lib/scsi/rigid,  /usr/lib/scsi/save-\nchanges,  /usr/lib/scsi/save-file,  /usr/lib/scsi/tworands, /usr/lib/scsi/verify (Tcl/Tk sub‐\nroutines used by scsi-config).\n/dev/sd*\n/dev/sg*\n/dev/scd*\n/dev/st*\n/dev/nst*\n/dev/rmt*\n/dev/nrmt*\n\n",
            "subsections": []
        },
        "SEE ALSO": {
            "content": "scsiinfo(8), scsiformat(8), tkscsiformat(8), fdisk(8), sd(4),\n",
            "subsections": [
                {
                    "name": "Draft proposed",
                    "content": ""
                },
                {
                    "name": "American National Standard",
                    "content": ""
                },
                {
                    "name": "for information systems",
                    "content": "SMALL COMPUTER SYSTEM INTERFACE - 2"
                },
                {
                    "name": "(SCSI-2)",
                    "content": ""
                },
                {
                    "name": "MARCH 9, 1990",
                    "content": ""
                }
            ]
        },
        "AUTHORS": {
            "content": "Eric Youngdale.\nMichael Weller <eowmob@exp-math.uni-essen.de>, Versions 1.5 & 1.7\n\nscsiinfo 1.7                               24 August 1997                             scsi-config(8)",
            "subsections": []
        }
    },
    "summary": "scsi-config - query information from a scsi device with a nice user interface",
    "flags": [],
    "examples": [],
    "see_also": [
        {
            "name": "scsiinfo",
            "section": "8",
            "url": "https://www.chedong.com/phpMan.php/man/scsiinfo/8/json"
        },
        {
            "name": "scsiformat",
            "section": "8",
            "url": "https://www.chedong.com/phpMan.php/man/scsiformat/8/json"
        },
        {
            "name": "tkscsiformat",
            "section": "8",
            "url": "https://www.chedong.com/phpMan.php/man/tkscsiformat/8/json"
        },
        {
            "name": "fdisk",
            "section": "8",
            "url": "https://www.chedong.com/phpMan.php/man/fdisk/8/json"
        },
        {
            "name": "sd",
            "section": "4",
            "url": "https://www.chedong.com/phpMan.php/man/sd/4/json"
        }
    ]
}