# man > access(5)

[_ACCESS_(5)](https://www.chedong.com/phpMan.php/man/ACCESS/5/markdown)                                File Formats Manual                               [_ACCESS_(5)](https://www.chedong.com/phpMan.php/man/ACCESS/5/markdown)

## NAME
       access - Postfix SMTP server access table

## SYNOPSIS
### postmap /etc/postfix/access

       **postmap -q "_**string_**" /etc/postfix/access**

       **postmap -q - /etc/postfix/access <_**inputfile_

## DESCRIPTION
       This document describes access control on remote SMTP client information: host names, network
       addresses,  and envelope sender or recipient addresses; it is implemented by the Postfix SMTP
       server.  See [**header_checks**(5)](https://www.chedong.com/phpMan.php/man/headerchecks/5/markdown) or [**body_checks**(5)](https://www.chedong.com/phpMan.php/man/bodychecks/5/markdown) for access control on the  content  of  email
       messages.

       Normally,  the  [**access**(5)](https://www.chedong.com/phpMan.php/man/access/5/markdown)  table  is  specified  as  a  text file that serves as input to the
       [**postmap**(1)](https://www.chedong.com/phpMan.php/man/postmap/1/markdown) command.  The result, an indexed file in **dbm  **or  **db  **format,  is  used  for  fast
       searching by the mail system. Execute the command "**postmap /etc/postfix/access**" to rebuild an
       indexed file after changing the corresponding text file.

       When  the  table  is  provided via other means such as NIS, LDAP or SQL, the same lookups are
       done as for ordinary indexed files.

       Alternatively, the table can be provided as a regular-expression map where patterns are given
       as regular expressions, or lookups can be directed to a TCP-based server. In those cases, the
       lookups are done in a slightly different way as described below under "REGULAR EXPRESSION TA‐
       BLES" or "TCP-BASED TABLES".

## CASE FOLDING
       The search string is folded to lowercase before database  lookup.  As  of  Postfix  2.3,  the
       search  string  is  not case folded with database types such as regexp: or pcre: whose lookup
       fields can match both upper and lower case.

## TABLE FORMAT
       The input format for the [**postmap**(1)](https://www.chedong.com/phpMan.php/man/postmap/1/markdown) command is as follows:

       _pattern_ _action_
              When _pattern_ matches a mail address, domain or host address, perform the corresponding
              _action_.

       blank lines and comments
              Empty lines and whitespace-only lines are ignored, as are lines whose first non-white‐
              space character is a `#'.

       multi-line text
              A logical line starts with non-whitespace text. A line  that  starts  with  whitespace
              continues a logical line.

## EMAIL ADDRESS PATTERNS
       With lookups from indexed files such as DB or DBM, or from networked tables such as NIS, LDAP
       or SQL, patterns are tried in the order as listed below:

       _user_@_domain_
              Matches the specified mail address.

       _domain.tld_
              Matches _domain.tld_ as the domain part of an email address.

              The  pattern  _domain.tld_  also  matches subdomains, but only when the string **smtpd_ac‐**
              **cess_maps **is listed in the Postfix **parent_domain_matches_subdomains **configuration set‐
              ting.

       _.domain.tld_
              Matches subdomains of _domain.tld_, but only when the string  **smtpd_access_maps  **is  not
              listed in the Postfix **parent_domain_matches_subdomains **configuration setting.

       _user_@  Matches all mail addresses with the specified user part.

       Note:  lookup  of the null sender address is not possible with some types of lookup table. By
       default, Postfix uses **<> **as the lookup key for such addresses. The value  is  specified  with
       the **smtpd_null_access_lookup_key **parameter in the Postfix **main.cf **file.

## EMAIL ADDRESS EXTENSION
       When  a  mail address localpart contains the optional recipient delimiter (e.g., _user+foo_@_do‐_
       _main_), the lookup order becomes: _user+foo_@_domain_, _user_@_domain_, _domain_, _user+foo_@, and _user_@.

## HOST NAME/ADDRESS PATTERNS
       With lookups from indexed files such as DB or DBM, or from networked tables such as NIS, LDAP
       or SQL, the following lookup patterns are examined in the order as listed:

       _domain.tld_
              Matches _domain.tld_.

              The pattern _domain.tld_ also matches subdomains, but only  when  the  string  **smtpd_ac‐**
              **cess_maps **is listed in the Postfix **parent_domain_matches_subdomains **configuration set‐
              ting.

       _.domain.tld_
              Matches  subdomains  of  _domain.tld_, but only when the string **smtpd_access_maps **is not
              listed in the Postfix **parent_domain_matches_subdomains **configuration setting.

       _net.work.addr.ess_

       _net.work.addr_

       _net.work_

       _net_    Matches a remote IPv4 host address or network address range.  Specify one to four dec‐
              imal octets separated by ".". Do not specify "[]" , "/", leading zeros, or hexadecimal
              forms.

              Network ranges are matched by repeatedly truncating the last ".octet"  from  a  remote
              IPv4 host address string, until a match is found in the access table, or until further
              truncation is not possible.

              NOTE: use the **cidr **lookup table type to specify network/netmask patterns. See **cidr_ta‐**
              [**ble**(5)](https://www.chedong.com/phpMan.php/man/ble/5/markdown) for details.

       _net:work:addr:ess_

       _net:work:addr_

       _net:work_

       _net_    Matches  a  remote IPv6 host address or network address range.  Specify three to eight
              hexadecimal octet pairs separated by ":", using the compressed form  "::"  for  a  se‐
              quence  of  zero-valued  octet  pairs.  Do  not  specify  "[]", "/", leading zeros, or
              non-compressed forms.

              A network range is matched by repeatedly truncating the  last  ":octetpair"  from  the
              compressed-form  remote IPv6 host address string, until a match is found in the access
              table, or until further truncation is not possible.

              NOTE: use the **cidr **lookup table type to specify network/netmask patterns. See **cidr_ta‐**
              [**ble**(5)](https://www.chedong.com/phpMan.php/man/ble/5/markdown) for details.

              IPv6 support is available in Postfix 2.2 and later.

## ACCEPT ACTIONS
       **OK     **Accept the address etc. that matches the pattern.

       _all-numerical_
              An all-numerical result is treated as OK. This format is  generated  by  address-based
              relay authorization schemes such as pop-before-smtp.

       For other accept actions, see "OTHER ACTIONS" below.

## REJECT ACTIONS
       Postfix  version 2.3 and later support enhanced status codes as defined in RFC 3463.  When no
       code is specified at the beginning of the _text_ below, Postfix inserts a default enhanced sta‐
       tus code of "5.7.1" in the case of reject actions, and "4.7.1" in the case of defer  actions.
       See "ENHANCED STATUS CODES" below.

       **4_**NN_ _text_

       **5_**NN_ _text_
              Reject  the  address  etc.  that  matches  the pattern, and respond with the numerical
              three-digit code and text. **4_**NN_ means "try again later", while **5_**NN_ means  "do  not  try
              again".

              The following responses have special meaning for the Postfix SMTP server:

              **421 _**text_ (Postfix 2.3 and later)

              **521 _**text_ (Postfix 2.6 and later)
                     After responding with the numerical three-digit code and text, disconnect imme‐
                     diately from the SMTP client.  This frees up SMTP server resources so that they
                     can be made available to another SMTP client.

                     Note:  The  "521"  response  should be used only with botnets and other malware
                     where interoperability is of no concern.  The "send 521 and disconnect"  behav‐
                     ior is NOT defined in the SMTP standard.

       **REJECT _**optional_ _text..._
              Reject  the address etc. that matches the pattern. Reply with "**$access_map_reject_code**
              _optional_ _text..._" when the optional text is specified, otherwise reply with a  generic
              error response message.

       **DEFER _**optional_ _text..._
              Reject  the  address etc. that matches the pattern. Reply with "**$access_map_defer_code**
              _optional_ _text..._" when the optional text is specified, otherwise reply with a  generic
              error response message.

              This feature is available in Postfix 2.6 and later.

       **DEFER_IF_REJECT _**optional_ _text..._
              Defer  the  request  if  some later restriction would result in a REJECT action. Reply
              with "**$access_map_defer_code 4.7.1 _**optional_ _text..._" when the optional text is  speci‐
              fied, otherwise reply with a generic error response message.

              Prior to Postfix 2.6, the SMTP reply code is 450.

              This feature is available in Postfix 2.1 and later.

       **DEFER_IF_PERMIT _**optional_ _text..._
              Defer  the  request  if some later restriction would result in an explicit or implicit
              PERMIT action.  Reply with "**$access_map_defer_code 4.7.1  _**optional_ _text..._"  when  the
              optional text is specified, otherwise reply with a generic error response message.

              Prior to Postfix 2.6, the SMTP reply code is 450.

              This feature is available in Postfix 2.1 and later.

       For other reject actions, see "OTHER ACTIONS" below.

## OTHER ACTIONS
       _restriction..._
              Apply  the named UCE restriction(s) (**permit**, **reject**, **reject_unauth_destination**, and so
              on).

       **BCC _**user@domain_
              Send one copy of the message to the specified recipient.

              If multiple BCC actions are specified within the  same  SMTP  MAIL  transaction,  with
              Postfix 3.0 only the last action will be used.

              This feature is available in Postfix 3.0 and later.

       **DISCARD _**optional_ _text..._
              Claim  successful delivery and silently discard the message.  Log the optional text if
              specified, otherwise log a generic message.

              Note: this action currently affects all recipients of the message.   To  discard  only
              one recipient without discarding the entire message, use the [transport(5)](https://www.chedong.com/phpMan.php/man/transport/5/markdown) table to di‐
              rect mail to the [discard(8)](https://www.chedong.com/phpMan.php/man/discard/8/markdown) service.

              This feature is available in Postfix 2.0 and later.

       **DUNNO  **Pretend  that  the  lookup  key  was not found. This prevents Postfix from trying sub‐
              strings of the lookup key (such as a subdomain name, or a network address subnetwork).

              This feature is available in Postfix 2.0 and later.

       **FILTER _**transport:destination_
              After the message is queued, send the entire message through  the  specified  external
              content  filter. The _transport_ name specifies the first field of a mail delivery agent
              definition in master.cf; the syntax of the next-hop _destination_ is  described  in  the
              manual page of the corresponding delivery agent.  More information about external con‐
              tent filters is in the Postfix FILTER_README file.

              Note  1: do not use $_number_ regular expression substitutions for _transport_ or _destina‐_
              _tion_ unless you know that the information has a trusted origin.

              Note 2: this action overrides the main.cf **content_filter **setting, and affects all  re‐
              cipients  of the message. In the case that multiple **FILTER **actions fire, only the last
              one is executed.

              Note 3: the purpose of the FILTER command is to override message routing.  To override
              the recipient's _transport_ but not the next-hop _destination_, specify  an  empty  filter
              _destination_  (Postfix 2.7 and later), or specify a _transport:destination_ that delivers
              through a different Postfix instance (Postfix 2.6 and earlier). Other options are  us‐
              ing  the  recipient-dependent **transport_maps **or the sender-dependent **sender_dependent‐**
              **_default_transport_maps **features.

              This feature is available in Postfix 2.0 and later.

       **HOLD _**optional_ _text..._
              Place the message on the **hold **queue, where it will sit until someone either deletes it
              or releases it for delivery.  Log the optional text  if  specified,  otherwise  log  a
              generic message.

              Mail  that  is  placed on hold can be examined with the [**postcat**(1)](https://www.chedong.com/phpMan.php/man/postcat/1/markdown) command, and can be
              destroyed or released with the [**postsuper**(1)](https://www.chedong.com/phpMan.php/man/postsuper/1/markdown) command.

              Note: use "**postsuper -r**" to release mail that was kept on hold for a significant frac‐
              tion of **$maximal_queue_lifetime **or **$bounce_queue_lifetime**, or longer.  Use  "**postsuper**
              **-H**" only for mail that will not expire within a few delivery attempts.

              Note: this action currently affects all recipients of the message.

              This feature is available in Postfix 2.0 and later.

       **PREPEND _**headername:_ _headervalue_
              Prepend  the  specified message header to the message.  When more than one PREPEND ac‐
              tion executes, the first prepended header appears before  the  second  etc.  prepended
              header.

              Note:  this action must execute before the message content is received; it cannot exe‐
              cute in the context of **smtpd_end_of_data_restrictions**.

              This feature is available in Postfix 2.1 and later.

       **REDIRECT _**user@domain_
              After the message is queued, send the message to the specified address instead of  the
              intended  recipient(s).   When multiple **REDIRECT **actions fire, only the last one takes
              effect.

              Note: this action overrides the FILTER action, and currently overrides all  recipients
              of the message.

              This feature is available in Postfix 2.1 and later.

       **INFO _**optional_ _text..._
              Log  an  informational record with the optional text, together with client information
              and if available, with helo, sender, recipient and protocol information.

              This feature is available in Postfix 3.0 and later.

       **WARN _**optional_ _text..._
              Log a warning with the optional text, together with client information and  if  avail‐
              able, with helo, sender, recipient and protocol information.

              This feature is available in Postfix 2.1 and later.

## ENHANCED STATUS CODES
       Postfix  version 2.3 and later support enhanced status codes as defined in RFC 3463.  When an
       enhanced status code is specified in an access table, it is subject to modification. The fol‐
       lowing transformations are needed when the same  access  table  is  used  for  client,  helo,
       sender,  or  recipient access restrictions; they happen regardless of whether Postfix replies
       to a MAIL FROM, RCPT TO or other SMTP command.

       •      When a sender address matches a REJECT action, the Postfix SMTP server will  transform
              a  recipient  DSN status (e.g., 4.1.1-4.1.6) into the corresponding sender DSN status,
              and vice versa.

       •      When non-address information matches a REJECT action (such as the HELO  command  argu‐
              ment  or the client hostname/address), the Postfix SMTP server will transform a sender
              or recipient DSN status into a generic non-address DSN status (e.g., 4.0.0).

## REGULAR EXPRESSION TABLES
       This section describes how the table lookups change when the table is given in  the  form  of
       regular  expressions.  For  a description of regular expression lookup table syntax, see **reg‐**
       [**exp_table**(5)](https://www.chedong.com/phpMan.php/man/exptable/5/markdown) or [**pcre_table**(5)](https://www.chedong.com/phpMan.php/man/pcretable/5/markdown).

       Each pattern is a regular expression that is applied to the entire string  being  looked  up.
       Depending  on  the application, that string is an entire client hostname, an entire client IP
       address, or an entire mail address. Thus, no parent domain or parent network search is  done,
       _user@domain_  mail  addresses are not broken up into their _user@_ and _domain_ constituent parts,
       nor is _user+foo_ broken up into _user_ and _foo_.

       Patterns are applied in the order as specified in the table, until a pattern  is  found  that
       matches the search string.

       Actions are the same as with indexed file lookups, with the additional feature that parenthe‐
       sized substrings from the pattern can be interpolated as **$1**, **$2 **and so on.

## TCP-BASED TABLES
       This  section describes how the table lookups change when lookups are directed to a TCP-based
       server. For a description of the TCP client/server lookup protocol, see  [**tcp_table**(5)](https://www.chedong.com/phpMan.php/man/tcptable/5/markdown).   This
       feature is not available up to and including Postfix version 2.4.

       Each  lookup operation uses the entire query string once.  Depending on the application, that
       string is an entire client hostname, an entire client IP address, or an entire mail  address.
       Thus,  no  parent domain or parent network search is done, _user@domain_ mail addresses are not
       broken up into their _user@_ and _domain_ constituent parts, nor is _user+foo_ broken up into  _user_
       and _foo_.

       Actions are the same as with indexed file lookups.

## EXAMPLE
       The  following example uses an indexed file, so that the order of table entries does not mat‐
       ter. The example permits access by the client  at  address  1.2.3.4  but  rejects  all  other
       clients  in 1.2.3.0/24. Instead of **hash **lookup tables, some systems use **dbm**.  Use the command
       "**postconf -m**" to find out what lookup tables Postfix supports on your system.

       /etc/postfix/main.cf:
           smtpd_client_restrictions =
               check_client_access hash:/etc/postfix/access

       /etc/postfix/access:
           1.2.3   REJECT
           1.2.3.4 OK

       Execute the command "**postmap /etc/postfix/access**" after editing the file.

## BUGS
       The table format does not understand quoting conventions.

## SEE ALSO
       [postmap(1)](https://www.chedong.com/phpMan.php/man/postmap/1/markdown), Postfix lookup table manager
       [smtpd(8)](https://www.chedong.com/phpMan.php/man/smtpd/8/markdown), SMTP server
       [postconf(5)](https://www.chedong.com/phpMan.php/man/postconf/5/markdown), configuration parameters
       [transport(5)](https://www.chedong.com/phpMan.php/man/transport/5/markdown), transport:nexthop syntax

## README FILES
       Use "**postconf readme_directory**" or "**postconf html_directory**" to locate this information.
       SMTPD_ACCESS_README, built-in SMTP server access control
       DATABASE_README, Postfix lookup table overview

## LICENSE
       The Secure Mailer license must be distributed with this software.

**AUTHOR(S)**
       Wietse Venema
       IBM T.J. Watson Research
       P.O. Box 704
       Yorktown Heights, NY 10598, USA

       Wietse Venema
       Google, Inc.
       111 8th Avenue
       New York, NY 10011, USA

                                                                                           [_ACCESS_(5)](https://www.chedong.com/phpMan.php/man/ACCESS/5/markdown)
