# IP-ADDRESS - protocol address management - man(8) - [phpMan]

[_IP-ADDRESS_(8)](https://www.chedong.com/phpMan.php/man/IP-ADDRESS/8/markdown)                                   Linux                                  [_IP-ADDRESS_(8)](https://www.chedong.com/phpMan.php/man/IP-ADDRESS/8/markdown)

## NAME
       ip-address - protocol address management

## SYNOPSIS
       **ip **[ _OPTIONS_ ] **address  **{ _COMMAND_ | **help **}


       **ip address **{ **add **| **change **| **replace **} _IFADDR_ **dev _**IFNAME_ [ _LIFETIME_ ] [ _CONFFLAG-LIST_ ]

       **ip address del _**IFADDR_ **dev _**IFNAME_ **[ _**mngtmpaddr_ **]**

       **ip address **{ **save **| **flush **} [ **dev _**IFNAME_ ] [ **scope _**SCOPE-ID_ ] [ **metric _**METRIC_ ] [ **to _**PREFIX_ ]
               [ _FLAG-LIST_ ] [ **label _**PATTERN_ ] [ _up_ ]

       **ip address **[ **show **[ **dev _**IFNAME_ ] [ **scope _**SCOPE-ID_ ] [ **to _**PREFIX_ ] [ _FLAG-LIST_ ] [ **label _**PAT‐_
               _TERN_ ] [ **master _**DEVICE_ ] [ **type _**TYPE_ ] [ **vrf _**NAME_ ] [ **up **] [ **nomaster **] ]

       **ip address **{ **showdump **| **restore **}

       _IFADDR_ := _PREFIX_ | _ADDR_ **peer _**PREFIX_ [ **broadcast _**ADDR_ ] [ **anycast _**ADDR_ ] [ **label _**LABEL_ ] [
               **scope _**SCOPE-ID_ ]

       _SCOPE-ID_ := [ **host **| **link **| **global **| _NUMBER_ ]

       _FLAG-LIST_ := [ _FLAG-LIST_ ] _FLAG_

       _FLAG_ := [ [**-**]**permanent **| [**-**]**dynamic **| [**-**]**secondary **| [**-**]**primary **| [**-**]**tentative **| [**-**]**depre‐**
               **cated **| [**-**]**dadfailed **| [**-**]**temporary **| _CONFFLAG-LIST_ ]

       _CONFFLAG-LIST_ := [ _CONFFLAG-LIST_ ] _CONFFLAG_

       _CONFFLAG_ := [ **home **| **mngtmpaddr **| **nodad **| **optimistic **| **noprefixroute **| **autojoin **]

       _LIFETIME_ := [ **valid_lft _**LFT_ ] [ **preferred_lft _**LFT_ ]

       _LFT_ := [ **forever **| _SECONDS_ ]

       _TYPE_ := [ **bridge **| **bridge_slave **| **bond **| **bond_slave **| **can **| **dummy **| **hsr **| **ifb **| **ipoib **|
               **macvlan **| **macvtap **| **vcan **| **veth **| **vlan **| **vxlan **| **ip6tnl **| **ipip **| **sit **| **gre **| **gretap **|
               **erspan **| **ip6gre **| **ip6gretap **| **ip6erspan **| **vti **| **vrf **| **nlmon **| **ipvlan **| **lowpan **| **gen‐**
               **eve **| **macsec **]


## DESCRIPTION
       The **address **is a protocol (IPv4 or IPv6) address attached to a network device. Each device
       must have at least one address to use the corresponding protocol. It is possible to have sev‐
       eral different addresses attached to one device. These addresses are not discriminated, so
       that the term **alias **is not quite appropriate for them and we do not use it in this document.

       The **ip address **command displays addresses and their properties, adds new addresses and
       deletes old ones.


### ip address add - add new protocol address.
       **dev _**IFNAME_
              the name of the device to add the address to.


       **local _**ADDRESS_ **(default)**
              the address of the interface. The format of the address depends on the protocol. It is
              a  dotted  quad for IP and a sequence of hexadecimal halfwords separated by colons for
              IPv6. The _ADDRESS_ may be followed by a slash and a decimal number  which  encodes  the
              network prefix length.


       **peer _**ADDRESS_
              the address of the remote endpoint for pointopoint interfaces.  Again, the _ADDRESS_ may
              be  followed by a slash and a decimal number, encoding the network prefix length. If a
              peer address is specified, the local address cannot have a prefix length. The  network
              prefix is associated with the peer rather than with the local address.


       **broadcast _**ADDRESS_
              the broadcast address on the interface.

              It  is  possible  to  use the special symbols **'+' **and **'-' **instead of the broadcast ad‐
              dress. In this case, the broadcast address is derived by  setting/resetting  the  host
              bits of the interface prefix.


       **label _**LABEL_
              Each  address  may be tagged with a label string.  The maximum allowed total length of
              label is 15 characters.


       **scope _**SCOPE_VALUE_
              the scope of the area where this address is valid.  The available scopes are listed in
              file **/etc/iproute2/rt_scopes**.  Predefined scope values are:

                      **global **- the address is globally valid.

                      **site **- (IPv6 only, deprecated) the address is site local, i.e. it is valid in‐
                      side this site.

                      **link **- the address is link local, i.e. it is valid only on this device.

                      **host **- the address is valid only inside this host.


       **metric _**NUMBER_
              priority of prefix route associated with address.


       **valid_lft _**LFT_
              the valid lifetime of this address; see section 5.5.4 of RFC 4862.  When  it  expires,
              the address is removed by the kernel.  Defaults to **forever**.


       **preferred_lft _**LFT_
              the  preferred  lifetime  of  this address; see section 5.5.4 of RFC 4862. When it ex‐
              pires, the address is no longer used for new outgoing connections.  Defaults  to  **for‐**
              **ever**.


       **home   **(IPv6 only) designates this address the "home address" as defined in RFC 6275.


### mngtmpaddr
              (IPv6  only)  make the kernel manage temporary addresses created from this one as tem‐
              plate on behalf of Privacy Extensions  (RFC3041).  For  this  to  become  active,  the
              **use_tempaddr **sysctl setting has to be set to a value greater than zero.  The given ad‐
              dress  needs to have a prefix length of 64. This flag allows to use privacy extensions
              in a manually configured network, just like if stateless  auto-configuration  was  ac‐
              tive.


       **nodad  **(IPv6 only) do not perform Duplicate Address Detection (RFC 4862) when adding this ad‐
              dress.


### optimistic
              (IPv6  only)  When performing Duplicate Address Detection, use the RFC 4429 optimistic
              variant.


### noprefixroute
              Do not automatically create a route for the network prefix of the added  address,  and
              don't  search  for one to delete when removing the address. Changing an address to add
              this flag will remove the automatically added prefix route, changing it to remove this
              flag will create the prefix route automatically.


### autojoin
              Joining multicast groups on Ethernet level via **ip maddr **command does not work if  con‐
              nected to an Ethernet switch that does IGMP snooping since the switch would not repli‐
              cate  multicast  packets on ports that did not have IGMP reports for the multicast ad‐
              dresses.

              Linux VXLAN interfaces created via **ip link add vxlan **have the **group  **option  that  en‐
              ables them to do the required join.

              Using  the **autojoin **flag when adding a multicast address enables similar functionality
              for Openvswitch VXLAN interfaces as well as other tunneling mechanisms  that  need  to
              receive multicast traffic.


### ip address delete - delete protocol address
       **Arguments:  **coincide  with the arguments of **ip addr add.  **The device name is a required argu‐
       ment. The rest are optional.  If no arguments are given, the first address is deleted.


### ip address show - look at protocol addresses
       **dev _**IFNAME_ **(default)**
              name of device.


       **scope _**SCOPE_VAL_
              only list addresses with this scope.


       **to _**PREFIX_
              only list addresses matching this prefix.


       **label _**PATTERN_
              only list addresses with labels matching the _PATTERN_.  _PATTERN_ is a usual shell  style
              pattern.


       **master _**DEVICE_
              only list interfaces enslaved to this master device.


       **vrf _**NAME_
              only list interfaces enslaved to this vrf.


       **type _**TYPE_
              only list interfaces of the given type.

              Note  that  the type name is not checked against the list of supported types - instead
              it is sent as-is to the kernel. Later it is used to filter the returned interface list
              by comparing it with the relevant attribute in case the kernel didn't filter  already.
              Therefore any string is accepted, but may lead to empty output.


       **up     **only list running interfaces.


### nomaster
              only list interfaces with no master.


       **dynamic **and **permanent**
              (IPv6  only)  only  list addresses installed due to stateless address configuration or
              only list permanent (not dynamic) addresses. These two  flags  are  inverses  of  each
              other, so **-dynamic **is equal to **permanent **and **-permanent **is equal to **dynamic**.


### tentative
              (IPv6 only) only list addresses which have not yet passed duplicate address detection.


### -tentative
              (IPv6  only) only list addresses which are not in the process of duplicate address de‐
              tection currently.


### deprecated
              (IPv6 only) only list deprecated addresses.


### -deprecated
              (IPv6 only) only list addresses not being deprecated.


### dadfailed
              (IPv6 only) only list addresses which have failed duplicate address detection.


### -dadfailed
              (IPv6 only) only list addresses which have not failed duplicate address detection.


       **temporary **or **secondary**
              List temporary IPv6 or secondary IPv4 addresses only. The Linux kernel shares a single
              bit for those, so they are actually aliases for each other although the  meaning  dif‐
              fers depending on address family.


### -temporary  -secondary
              These flags are aliases for **primary**.


### primary
              List  only primary addresses, in IPv6 exclude temporary ones. This flag is the inverse
              of **temporary **and **secondary**.


### -primary
              This is an alias for **temporary **or **secondary**.


### ip address flush - flush protocol addresses
       This command flushes the protocol addresses selected by some criteria.


       This command has the same arguments as **show **except that **type **and  **master  **selectors  are  not
       supported.  Another difference is that it does not run when no arguments are given.


       **Warning:  **This  command and other **flush **commands are unforgiving. They will cruelly purge all
       the addresses.


       With the **-statistics **option, the command becomes verbose. It prints out the number of deleted
       addresses and the number of rounds made to flush the address list.  If this option  is  given
       twice,  **ip  address flush **also dumps all the deleted addresses in the format described in the
       previous subsection.


## EXAMPLES
       ip address show
           Shows IPv4 and IPv6 addresses assigned to all network interfaces. The  'show'  subcommand
           can be omitted.

       ip address show up
           Same as above except that only addresses assigned to active network interfaces are shown.

       ip address show dev eth0
           Shows IPv4 and IPv6 addresses assigned to network interface eth0.

       ip address add 2001:0db8:[85a3::0370](https://www.chedong.com/phpMan.php/perldoc/85a3%3A%3A0370/markdown):7334/64 dev eth1
           Adds an IPv6 address to network interface eth1.

       ip address delete 2001:0db8:[85a3::0370](https://www.chedong.com/phpMan.php/perldoc/85a3%3A%3A0370/markdown):7334/64 dev eth1
           Delete the IPv6 address added above.

       ip address flush dev eth4 scope global
           Removes  all  global  IPv4 and IPv6 addresses from device eth4. Without 'scope global' it
           would remove all addresses including IPv6 link-local ones.


## SEE ALSO
       [**ip**(8)](https://www.chedong.com/phpMan.php/man/ip/8/markdown)


## AUTHOR
       Original Manpage by Michail Litvak <<mci@owl.openwall.com>>

iproute2                                     20 Dec 2011                               [_IP-ADDRESS_(8)](https://www.chedong.com/phpMan.php/man/IP-ADDRESS/8/markdown)
