# DROP_STATISTICS - remove extended statistics - man(7) - [phpMan]

_DROP_ [_STATISTICS_(7)](https://www.chedong.com/phpMan.php/man/STATISTICS/7/markdown)                 PostgreSQL 16.14 Documentation                 _DROP_ [_STATISTICS_(7)](https://www.chedong.com/phpMan.php/man/STATISTICS/7/markdown)

## NAME
       DROP_STATISTICS - remove extended statistics

## SYNOPSIS
       DROP STATISTICS [ IF EXISTS ] _name_ [, ...] [ CASCADE | RESTRICT ]

## DESCRIPTION
       **DROP STATISTICS **removes statistics object(s) from the database. Only the statistics object's
       owner, the schema owner, or a superuser can drop a statistics object.

## PARAMETERS
       IF EXISTS
           Do not throw an error if the statistics object does not exist. A notice is issued in this
           case.

       _name_
           The name (optionally schema-qualified) of the statistics object to drop.

       CASCADE
       RESTRICT
           These key words do not have any effect, since there are no dependencies on statistics.

## EXAMPLES
       To destroy two statistics objects in different schemas, without failing if they don't exist:

           DROP STATISTICS IF EXISTS
               accounting.users_uid_creation,
               public.grants_user_role;

## COMPATIBILITY
       There is no **DROP STATISTICS **command in the SQL standard.

## SEE ALSO
       ALTER STATISTICS ([**ALTER_STATISTICS**(7)](https://www.chedong.com/phpMan.php/man/ALTERSTATISTICS/7/markdown)), CREATE STATISTICS ([**CREATE_STATISTICS**(7)](https://www.chedong.com/phpMan.php/man/CREATESTATISTICS/7/markdown))

PostgreSQL 16.14                                2026                              _DROP_ [_STATISTICS_(7)](https://www.chedong.com/phpMan.php/man/STATISTICS/7/markdown)
