{
    "mode": "man",
    "parameter": "DHCPCD",
    "section": "8",
    "url": "https://www.chedong.com/phpMan.php/man/DHCPCD/8/json",
    "generated": "2026-10-09T16:35:36Z",
    "synopsis": "dhcpcd  [-146ABbDdEGgHJKLMNPpqTV] [-C, --nohook hook] [-c, --script script] [-e, --env value]\n[-F,   --fqdn    FQDN]    [-f,    --config    file]    [-h,    --hostname    hostname]\n[-I,  --clientid clientid] [-i, --vendorclassid vendorclassid] [-j, --logfile logfile]\n[-l,  --leasetime   seconds]   [-m,   --metric   metric]   [-O,   --nooption   option]\n[-o,    --option    option]   [-Q,   --require   option]   [-r,   --request   address]\n[-S, --static value]  [-s,  --inform  address[/cidr[/broadcastaddress]]]  [--inform6]\n[-t,   --timeout   seconds]   [-u,  --userclass  class]  [-v,  --vendor  code,  value]\n[-W, --whitelist address[/cidr]]  [-w]  [--waitip=[4  |  6]]  [-y,  --reboot  seconds]\n[-X,      --blacklist      address[/cidr]]      [-Z,     --denyinterfaces     pattern]\n[-z, --allowinterfaces pattern] [--inactive] [--configure] [--noconfigure] [interface]\n[...]\ndhcpcd -n, --rebind [interface]\ndhcpcd -k, --release [interface]\ndhcpcd -U, --dumplease [interface]",
    "sections": {
        "NAME": {
            "content": "dhcpcd — a DHCP client\n",
            "subsections": []
        },
        "SYNOPSIS": {
            "content": "dhcpcd  [-146ABbDdEGgHJKLMNPpqTV] [-C, --nohook hook] [-c, --script script] [-e, --env value]\n[-F,   --fqdn    FQDN]    [-f,    --config    file]    [-h,    --hostname    hostname]\n[-I,  --clientid clientid] [-i, --vendorclassid vendorclassid] [-j, --logfile logfile]\n[-l,  --leasetime   seconds]   [-m,   --metric   metric]   [-O,   --nooption   option]\n[-o,    --option    option]   [-Q,   --require   option]   [-r,   --request   address]\n[-S, --static value]  [-s,  --inform  address[/cidr[/broadcastaddress]]]  [--inform6]\n[-t,   --timeout   seconds]   [-u,  --userclass  class]  [-v,  --vendor  code,  value]\n[-W, --whitelist address[/cidr]]  [-w]  [--waitip=[4  |  6]]  [-y,  --reboot  seconds]\n[-X,      --blacklist      address[/cidr]]      [-Z,     --denyinterfaces     pattern]\n[-z, --allowinterfaces pattern] [--inactive] [--configure] [--noconfigure] [interface]\n[...]\ndhcpcd -n, --rebind [interface]\ndhcpcd -k, --release [interface]\ndhcpcd -U, --dumplease [interface]",
            "subsections": [
                {
                    "name": "dhcpcd --version",
                    "content": "dhcpcd -x, --exit [interface]\n"
                }
            ]
        },
        "DESCRIPTION": {
            "content": "dhcpcd is an implementation of the DHCP client specified in RFC 2131.  dhcpcd gets  the  host\ninformation (IP address, routes, etc) from a DHCP server and configures the network interface\nof  the  machine  on  which  it  is running.  dhcpcd then runs the configuration script which\nwrites  DNS   information   to   resolvconf(8),   if   available,   otherwise   directly   to\n/etc/resolv.conf.  If the hostname is currently blank, (null) or localhost, or forcehostname\nis  YES  or  TRUE  or 1 then dhcpcd sets the hostname to the one supplied by the DHCP server.\ndhcpcd then daemonises and waits for the lease renewal time to lapse.  It will  then  attempt\nto  renew  its lease and reconfigure if the new lease changes when the lease begins to expire\nor the DHCP server sends a message to renew early.\n\nIf any interface reports a working carrier then dhcpcd will try  to  obtain  a  lease  before\nforking to the background, otherwise it will fork right away.  This behaviour can be modified\nwith the -b, --background and -w, --waitip options.\n\ndhcpcd is also an implementation of the BOOTP client specified in RFC 951.\n\ndhcpcd  is  also  an implementation of the IPv6 Router Solicitor as specified in RFC 4861 and\nRFC 6106.\n\ndhcpcd is also an implementation of the IPv6 Privacy Extensions to AutoConf as  specified  in\nRFC 4941.  This feature needs to be enabled in the kernel and dhcpcd will start using it.\n\ndhcpcd  is also an implementation of the DHCPv6 client as specified in RFC 3315.  By default,\ndhcpcd only starts DHCPv6 when instructed to do so by an IPV6 Router  Advertisement.   If  no\nIdentity Association is configured, then a Non-temporary Address is requested.\n",
            "subsections": [
                {
                    "name": "Local Link configuration",
                    "content": "If  dhcpcd  failed to obtain a lease, it probes for a valid IPv4LL address (aka ZeroConf, aka\nAPIPA).  Once obtained it restarts the process of looking for a DHCP server to get  a  proper\naddress.\n\nWhen  using IPv4LL, dhcpcd nearly always succeeds and returns an exit code of 0.  In the rare\ncase it fails, it normally means that there is a reverse ARP proxy installed which always de‐\nfeats IPv4LL probing.  To disable this behaviour, you can use the -L, --noipv4ll option.\n"
                },
                {
                    "name": "Multiple interfaces",
                    "content": "If a list of interfaces are given on the command line, then dhcpcd only works with those  in‐\nterfaces,  otherwise  dhcpcd  discovers available Ethernet interfaces that can be configured.\nWhen dhcpcd is not limited to one interface on the command line, it  is  running  in  Manager\nmode.  The dhcpcd-ui project expects dhcpcd to be running this way.\n\nIf  a single interface is given then dhcpcd only works for that interface and runs as a sepa‐\nrate instance to other dhcpcd processes.  The -w, --waitip option is enabled in this instance\nto maintain compatibility with older versions.  Using a single interface, optionally  further\nlimited  to  an  address protocol, also affects the -k, -N, -n and -x options, where the same\ninterface and any address protocol will need to be specified, as a lack of an interface  will\nimply Manager mode which this is not.  To force starting in Manager mode with only one inter‐\nface, the -M, --manager option can be used.\n\nInterfaces  are  preferred by carrier, DHCP lease/IPv4LL and then lowest metric.  For systems\nthat support route metrics, each route will be  tagged  with  the  metric,  otherwise  dhcpcd\nchanges  the  routes to use the interface with the same route and the lowest metric.  See op‐\ntions below for controlling which interfaces we allow and deny through the use of patterns.\n\nNon-ethernet interfaces and some virtual ethernet interfaces such as TAP and bridge  are  ig‐\nnored  by default, as is the FireWire interface.  To work with these devices they either need\nto be specified on the command line, be listed in --allowinterfaces or have an interface  di‐\nrective in /etc/dhcpcd.conf.\n"
                },
                {
                    "name": "Hooking into events",
                    "content": "dhcpcd runs /usr/lib/dhcpcd/dhcpcd-run-hooks, or the script specified by the -c, --script op‐\ntion.  This script runs each script found in /usr/lib/dhcpcd/dhcpcd-hooks in a lexical order.\nThe  default  installation supplies the scripts 01-test, 20-resolv.conf and 30-hostname.  You\ncan disable each script by using the -C, --nohook option.  See  dhcpcd-run-hooks(8)  for  de‐\ntails on how these scripts work.  dhcpcd currently ignores the exit code of the script.\n\nMore   scripts   are   supplied   in   /usr/share/dhcpcd/hooks  and  need  to  be  copied  to\n/usr/lib/dhcpcd/dhcpcd-hooks if you intend to use  them.   For  example,  you  could  install\n29-lookup-hostname  so  that  dhcpcd  can  lookup the hostname of the IP address in DNS if no\nhostname is given by the lease and one is not already set.\n"
                },
                {
                    "name": "Fine tuning",
                    "content": "You can fine-tune the behaviour of dhcpcd with the following options:\n"
                },
                {
                    "name": "-b --background",
                    "content": "Background immediately.  This is useful for startup scripts which don't disable  link\nmessages for carrier status.\n",
                    "flag": "-b",
                    "long": "--background"
                },
                {
                    "name": "-c --script _",
                    "content": "Use this script instead of the default /usr/lib/dhcpcd/dhcpcd-run-hooks.\n",
                    "flag": "-c",
                    "long": "--script"
                },
                {
                    "name": "-D --duid",
                    "content": "Use  a  DHCP  Unique Identifier.  If a system UUID is available, that will be used to\ncreate a DUID-UUID, otherwise if persistent storage  is  available  then  a  DUID-LLT\n(link  local address + time) is generated, otherwise DUID-LL is generated (link local\naddress).  The DUID type  can  be  hinted  as  an  optional  parameter  if  the  file\n/var/lib/dhcpcd/duid  does  not exist.  If not ll, lt or uuid then value will be con‐\nverted from 00:11:22:33 format.  This,  plus  the  IAID  will  be  used  as  the  -I,\n--clientid.   The  DUID generated will be held in /var/lib/dhcpcd/duid and should not\nbe copied to other hosts.  This file also takes precedence over the above  rules  ex‐\ncept for setting a value.\n",
                    "flag": "-D",
                    "long": "--duid"
                },
                {
                    "name": "-d --debug",
                    "content": "Echo debug messages to the stderr and syslog.\n",
                    "flag": "-d",
                    "long": "--debug"
                },
                {
                    "name": "-E --lastlease",
                    "content": "If  dhcpcd cannot obtain a lease, then try to use the last lease acquired for the in‐\nterface.\n",
                    "flag": "-E",
                    "long": "--lastlease"
                },
                {
                    "name": "--lastleaseextend",
                    "content": "Same as the above, but the lease will be retained even if it  expires.   dhcpcd  will\ngive  it up if any other host tries to claim it for their own via ARP.  This violates\nRFC 2131, section 3.7, which states the lease should be dropped once it has expired.\n",
                    "long": "--lastleaseextend"
                },
                {
                    "name": "-e --env _",
                    "content": "Push value to the environment for use in dhcpcd-run-hooks(8).  For example,  you  can\nforce the hostname hook to always set the hostname with -e forcehostname=YES.\n",
                    "flag": "-e",
                    "long": "--env"
                },
                {
                    "name": "-g --reconfigure",
                    "content": "dhcpcd  will re-apply IP address, routing and run dhcpcd-run-hooks(8) for each inter‐\nface.  This is useful so that a 3rd party such as PPP or VPN can change  the  routing\ntable  and  /  or  DNS,  etc  and then instruct dhcpcd to put things back afterwards.\ndhcpcd does not read a new configuration when this happens - you should rebind if you\nneed that functionality.\n",
                    "flag": "-g",
                    "long": "--reconfigure"
                },
                {
                    "name": "-F --fqdn _",
                    "content": "Requests that the DHCP server update DNS using  FQDN  instead  of  just  a  hostname.\nValid  values for fqdn are disable, none, ptr and both.  dhcpcd itself never does any\nDNS updates.  dhcpcd encodes the FQDN hostname as specified in RFC 1035.\n",
                    "flag": "-F",
                    "long": "--fqdn"
                },
                {
                    "name": "-f --config _",
                    "content": "Specify a config to load instead of /etc/dhcpcd.conf.  dhcpcd  always  processes  the\nconfig file before any command line options.\n",
                    "flag": "-f",
                    "long": "--config"
                },
                {
                    "name": "-h --hostname _",
                    "content": "Sends  hostname to the DHCP server so it can be registered in DNS.  If hostname is an\nempty string then the current system hostname is sent.  If hostname is a FQDN  (i.e.,\ncontains a .) then it will be encoded as such.\n",
                    "flag": "-h",
                    "long": "--hostname"
                },
                {
                    "name": "-I --clientid _",
                    "content": "Send  the  clientid.   If  the string is of the format 01:02:03 then it is encoded as\nhex.  For interfaces whose hardware address  is  longer  than  8  bytes,  or  if  the\nclientid is an empty string then dhcpcd sends a default clientid of the hardware fam‐\nily and the hardware address.\n",
                    "flag": "-I",
                    "long": "--clientid"
                },
                {
                    "name": "-i --vendorclassid _",
                    "content": "Override   the   DHCPv4  vendorclassid  field  sent.   The  default  is  dhcpcd-<ver‐\nsion>:<os>:<machine>:<platform>.  For example\ndhcpcd-5.5.6:NetBSD-6.99.5:i386:i386\nIf not set then none is sent.  Some badly configured DHCP servers reject unknown ven‐\ndorclassids.  To work around it, try and impersonate Windows by using the  MSFT  ven‐\ndorclassid.\n",
                    "flag": "-i",
                    "long": "--vendorclassid"
                },
                {
                    "name": "-j --logfile _",
                    "content": "Writes  to  the specified logfile.  dhcpcd still writes to syslog(3).  The logfile is\nreopened when dhcpcd receives the SIGUSR2 signal.\n",
                    "flag": "-j",
                    "long": "--logfile"
                },
                {
                    "name": "-k --release",
                    "content": "This causes an existing dhcpcd process running on the interface to release its  lease\nand  de-configure  the  interface  regardless  of the -p, --persistent option.  If no\ninterface is specified then this applies to all interfaces in Manager  mode.   If  no\ninterfaces are left running, dhcpcd will exit.\n",
                    "flag": "-k",
                    "long": "--release"
                },
                {
                    "name": "-l --leasetime _",
                    "content": "Request  a  lease time of seconds.  -1 represents an infinite lease time.  By default\ndhcpcd does not request any lease time and leaves it in the hands of the DHCP server.\n",
                    "flag": "-l",
                    "long": "--leasetime"
                },
                {
                    "name": "-M --manager",
                    "content": "Start dhcpcd in Manager mode even if only one  interface  specified  on  the  command\nline.  See the Multiple Interfaces section above.\n",
                    "flag": "-M",
                    "long": "--manager"
                },
                {
                    "name": "-m --metric _",
                    "content": "Metrics  are  used to prefer an interface over another one, lowest wins.  dhcpcd will\nsupply a default metric of 1000 + ifnametoindex(3).  This will be offset by 2000 for\nwireless interfaces, with additional offsets of 1000000 for IPv4LL  and  2000000  for\nroaming interfaces.\n",
                    "flag": "-m",
                    "long": "--metric"
                },
                {
                    "name": "-n --rebind",
                    "content": "Notifies  dhcpcd  to reload its configuration and rebind the specified interface.  If\nno interface is specified then this applies to all interfaces in  Manager  mode.   If\ndhcpcd is not running, then it starts up as normal.\n",
                    "flag": "-n",
                    "long": "--rebind"
                },
                {
                    "name": "-N --renew",
                    "content": "Notifies  dhcpcd  to  renew  existing  addresses  on  the specified interface.  If no\ninterface is specified then this applies to  all  interfaces  in  Manager  mode.   If\ndhcpcd  is  not running, then it starts up as normal.  Unlike the -n, --rebind option\nabove, the configuration for dhcpcd is not reloaded.\n",
                    "flag": "-N",
                    "long": "--renew"
                },
                {
                    "name": "-o --option _",
                    "content": "Request the DHCP option variable for use in /usr/lib/dhcpcd/dhcpcd-run-hooks.\n",
                    "flag": "-o",
                    "long": "--option"
                },
                {
                    "name": "-p --persistent",
                    "content": "dhcpcd de-configures the interface when it  exits  unless  this  option  is  enabled.\nSometimes,  this  isn't  desirable if, for example, you have root mounted over NFS or\nSSH clients connect to this host and they need to be notified of  the  host  shutting\ndown.  You can use this option to stop this from happening.\n",
                    "flag": "-p",
                    "long": "--persistent"
                },
                {
                    "name": "-r --request _",
                    "content": "Request  the address in the DHCP DISCOVER message.  There is no guarantee this is the\naddress the DHCP server will actually give.  If no address is given  then  the  first\naddress currently assigned to the interface is used.\n",
                    "flag": "-r",
                    "long": "--request"
                },
                {
                    "name": "-s --inform _",
                    "content": "Behaves  like -r, --request as above, but sends a DHCP INFORM instead of DISCOVER/RE‐\nQUEST.  This does not get a lease as such, just  notifies  the  DHCP  server  of  the\naddress in use.  You should also include the optional cidr network number in case the\naddress  is not already configured on the interface.  dhcpcd remains running and pre‐\ntends it has an infinite lease.  dhcpcd will not de-configure the interface  when  it\nexits.  If dhcpcd fails to contact a DHCP server then it returns a failure instead of\nfalling back on IPv4LL.\n",
                    "flag": "-s",
                    "long": "--inform"
                },
                {
                    "name": "--inform6",
                    "content": "Performs a DHCPv6 Information Request.  No address is requested or specified, but all\nother  DHCPv6 options are allowed.  This is normally performed automatically when the\nIPv6 Router Advertises that the client should perform this operation.  This option is\nonly needed when dhcpcd is not processing IPv6RA messages and the need for DHCPv6 In‐\nformation Request exists.\n",
                    "long": "--inform6"
                },
                {
                    "name": "-S --static _",
                    "content": "Configures a static DHCP value.  If you set ipaddress then dhcpcd will  not  attempt\nto obtain a lease and just use the value for the address with an infinite lease time.\n\nHere is an example which configures a static address, routes and DNS.\ndhcpcd -S ipaddress=192.168.0.10/24 \\\n-S routers=192.168.0.1 \\\n-S domainnameservers=192.168.0.1 \\\neth0\n\nYou cannot presently set static DHCPv6 values.  Use the -e, --env option instead.\n",
                    "flag": "-S",
                    "long": "--static"
                },
                {
                    "name": "-t --timeout _",
                    "content": "Timeout  after  seconds,  instead  of  the default 30.  A setting of 0 seconds causes\ndhcpcd to wait forever to get a lease.  If dhcpcd is working on  a  single  interface\nthen  dhcpcd  will  exit  when  a timeout occurs, otherwise dhcpcd will fork into the\nbackground.\n",
                    "flag": "-t",
                    "long": "--timeout"
                },
                {
                    "name": "-u --userclass _",
                    "content": "Tags the DHCPv4 message with the userclass class.  DHCP servers use this to give mem‐\nbers of the class DHCP options other than the default, without having to know  things\nlike hardware address or hostname.\n",
                    "flag": "-u",
                    "long": "--userclass"
                },
                {
                    "name": "-v --vendor _",
                    "content": "Add  an  encapsulated vendor option.  code should be between 1 and 254 inclusive.  To\nadd a raw vendor string, omit code but keep the comma.  Examples.\n\nSet the vendor option 01 with an IP address.\ndhcpcd -v 01,192.168.0.2 eth0\nSet the vendor option 02 with a hex code.\ndhcpcd -v 02,01:02:03:04:05 eth0\nSet the vendor option 03 with an IP address as a string.\ndhcpcd -v 03,\\\"192.168.0.2\\\" eth0\nSet un-encapsulated vendor option to hello world.\ndhcpcd -v ,\"hello world\" eth0\n",
                    "flag": "-v",
                    "long": "--vendor"
                },
                {
                    "name": "--version",
                    "content": "Display both program version and copyright information.  dhcpcd then exits before do‐\ning any configuration.\n",
                    "long": "--version"
                },
                {
                    "name": "-w",
                    "content": "an argument, unlike the below option.\n\n--waitip=[4 | 6]\nWait  for  an  address to be assigned before forking to the background.  4 means wait\nfor an IPv4 address to be assigned.  6 means wait for an IPv6 address to be assigned.\nIf no argument is given, dhcpcd will wait for any address protocol  to  be  assigned.\nIt  is  possible to wait for more than one address protocol and dhcpcd will only fork\nto the background when all waiting conditions are satisfied.\n",
                    "flag": "-w"
                },
                {
                    "name": "-x --exit",
                    "content": "This will signal an existing dhcpcd process running on the interface to exit.  If  no\ninterface  is specified, then the above is applied to all interfaces in Manager mode.\nSee the -p, --persistent option to control configuration persistence on  exit,  which\nis  enabled  by  default in dhcpcd.conf(5).  dhcpcd then waits until this process has\nexited.\n",
                    "flag": "-x",
                    "long": "--exit"
                },
                {
                    "name": "-y --reboot _",
                    "content": "Allow reboot seconds before moving to the discover phase if we have an old  lease  to\nuse.   Allow  reboot seconds before starting fallback states from the discover phase.\nIPv4LL is started when the first reboot timeout is reached.  The default  is  5  sec‐\nonds.   A setting of 0 seconds causes dhcpcd to skip the reboot phase and go straight\ninto discover.  This has no effect on DHCPv6 other than skipping the reboot phase.\n",
                    "flag": "-y",
                    "long": "--reboot"
                },
                {
                    "name": "Restricting behaviour",
                    "content": "dhcpcd will try to do as much as it can by default.  However, there are sometimes  situations\nwhere you don't want the things to be configured exactly how the DHCP server wants.  Here are\nsome options that deal with turning these bits off.\n\nNote that when dhcpcd is restricted to a single interface then the interface also needs to be\nspecified when asking dhcpcd to exit using the commandline.  If the protocol is restricted as\nwell then the protocol needs to be included with the exit instruction.\n"
                },
                {
                    "name": "-1 --oneshot",
                    "content": "Exit  after  configuring  an interface.  Use the -w, --waitip option to specify which\nprotocol(s) to configure before exiting.\n",
                    "flag": "-1",
                    "long": "--oneshot"
                },
                {
                    "name": "-4 --ipv4only",
                    "content": "Configure IPv4 only.\n",
                    "flag": "-4",
                    "long": "--ipv4only"
                },
                {
                    "name": "-6 --ipv6only",
                    "content": "Configure IPv6 only.\n",
                    "flag": "-6",
                    "long": "--ipv6only"
                },
                {
                    "name": "-A --noarp",
                    "content": "Don't request or claim the address by ARP.  This also disables IPv4LL.\n",
                    "flag": "-A",
                    "long": "--noarp"
                },
                {
                    "name": "-B --nobackground",
                    "content": "Don't run in the background when we acquire a lease.  This is mainly useful for  run‐\nning under the control of another process, such as a debugger or a network manager.\n",
                    "flag": "-B",
                    "long": "--nobackground"
                },
                {
                    "name": "-C --nohook _",
                    "content": "Don't run this hook script.  Matches full name, or prefixed with 2 numbers optionally\nending with .sh.\n\nSo to stop dhcpcd from touching your DNS settings you would do:-\ndhcpcd -C resolv.conf eth0\n",
                    "flag": "-C",
                    "long": "--nohook"
                },
                {
                    "name": "-G --nogateway",
                    "content": "Don't set any default routes.\n",
                    "flag": "-G",
                    "long": "--nogateway"
                },
                {
                    "name": "-H --xidhwaddr",
                    "content": "Use the last four bytes of the hardware address as the DHCP xid instead of a randomly\ngenerated number.\n",
                    "flag": "-H",
                    "long": "--xidhwaddr"
                },
                {
                    "name": "-J --broadcast",
                    "content": "Instructs  the DHCP server to broadcast replies back to the client.  Normally this is\nonly set for non-Ethernet interfaces, such as FireWire and InfiniBand.  In  most  in‐\nstances, dhcpcd will set this automatically.\n",
                    "flag": "-J",
                    "long": "--broadcast"
                },
                {
                    "name": "-K --nolink",
                    "content": "Don't  receive  link  messages  for carrier status.  You should only have to use this\nwith buggy device drivers or running dhcpcd through a network manager.\n",
                    "flag": "-K",
                    "long": "--nolink"
                },
                {
                    "name": "-L --noipv4ll",
                    "content": "Don't use IPv4LL (aka APIPA, aka Bonjour, aka ZeroConf).\n",
                    "flag": "-L",
                    "long": "--noipv4ll"
                },
                {
                    "name": "-O --nooption _",
                    "content": "Removes the option from the DHCP message before processing.\n",
                    "flag": "-O",
                    "long": "--nooption"
                },
                {
                    "name": "-P --printpidfile",
                    "content": "Print the pidfile dhcpcd will use based on command-line arguments to stdout.\n",
                    "flag": "-P",
                    "long": "--printpidfile"
                },
                {
                    "name": "-Q --require _",
                    "content": "Requires the option to be present in all DHCP messages, otherwise the message is  ig‐\nnored.   To  enforce that dhcpcd only responds to DHCP servers and not BOOTP servers,\nyou can -Q dhcpmessagetype.\n",
                    "flag": "-Q",
                    "long": "--require"
                },
                {
                    "name": "-q --quiet",
                    "content": "Quiet dhcpcd on the command line, only warnings and errors  will  be  displayed.   If\nthis option is used another time then all console output is disabled.  These messages\nare still logged via syslog(3).\n",
                    "flag": "-q",
                    "long": "--quiet"
                },
                {
                    "name": "-T --test",
                    "content": "On  receipt of DHCP messages just call /usr/lib/dhcpcd/dhcpcd-run-hooks with the rea‐\nson of TEST which echos the DHCP variables found in the message to the console.   The\ninterface  configuration  isn't touched and neither are any configuration files.  The\nrapidcommit option is not sent in TEST mode so that the server does not lease an ad‐\ndress.  To test INFORM the interface needs to be configured with the desired  address\nbefore starting dhcpcd.\n",
                    "flag": "-T",
                    "long": "--test"
                },
                {
                    "name": "-U --dumplease",
                    "content": "Dumps  the  current lease for the interface to stdout.  If no interface is given then\nall interfaces are dumped.  Use the -4 or -6 flags to specify an address family.   If\na lease is piped in via standard input then use the special interface named - to dump\nit.  In this case, specifying an address family is mandatory.\n",
                    "flag": "-U",
                    "long": "--dumplease"
                },
                {
                    "name": "-V --variables",
                    "content": "Display  a  list  of  option  codes,  the associated variable and encoding for use in\ndhcpcd-run-hooks(8).  Variables are prefixed with new and  old  unless  the  option\nnumber  is -.  Variables without an option are part of the DHCP message and cannot be\ndirectly requested.\n",
                    "flag": "-V",
                    "long": "--variables"
                },
                {
                    "name": "-W --whitelist _",
                    "content": "Only  accept  packets  from  address[/cidr].   -X,  --blacklist  is  ignored  if  -W,\n--whitelist is set.\n",
                    "flag": "-W",
                    "long": "--whitelist"
                },
                {
                    "name": "-X --blacklist _",
                    "content": "Ignore all packets from address[/cidr].\n",
                    "flag": "-X",
                    "long": "--blacklist"
                },
                {
                    "name": "-Z --denyinterfaces _",
                    "content": "When  discovering  interfaces,  the  interface name must not match pattern which is a\nspace or comma separated list of patterns passed to fnmatch(3).\n",
                    "flag": "-Z",
                    "long": "--denyinterfaces"
                },
                {
                    "name": "-z --allowinterfaces _",
                    "content": "When discovering interfaces, the interface name must match pattern which is  a  space\nor  comma  separated list of patterns passed to fnmatch(3).  If the same interface is\nmatched in -Z, --denyinterfaces then it is still denied.\n",
                    "flag": "-z",
                    "long": "--allowinterfaces"
                },
                {
                    "name": "--inactive",
                    "content": "Don't start any interfaces other than those specified on the command line.  This  al‐\nlows  dhcpcd  to  be started in Manager mode and then wait for subsequent dhcpcd com‐\nmands to start each interface as required.\n",
                    "long": "--inactive"
                },
                {
                    "name": "--configure",
                    "content": "Allows dhcpcd to configure the system.   This  is  the  default  behaviour  and  sets\nifconfigured=true.\n",
                    "long": "--configure"
                },
                {
                    "name": "--noconfigure",
                    "content": "dhcpcd  will  not  configure  the system at all.  This is only of use if the --script\nthat dhcpcd calls at each network event configures the system instead.  This is  dif‐\nferent  from -T, --test mode in that it's not one shot and the only change to the en‐\nvironment is the addition of ifconfigured=false.\n",
                    "long": "--noconfigure"
                },
                {
                    "name": "--nodev",
                    "content": "Don't load any /dev management modules.\n\n3RDPARTY LINK MANAGEMENT\nSome interfaces require configuration by 3rd parties, such as PPP or VPN.  When an  interface\nconfiguration  in  dhcpcd  is  marked as STATIC or INFORM without an address then dhcpcd will\nmonitor the interface until an address is added or removed from it and act accordingly.   For\npoint  to  point  interfaces  (like PPP), a default route to its destination is automatically\nadded to the configuration.  If the point to point interface is configured for  INFORM,  then\ndhcpcd unicasts INFORM to the destination, otherwise it defaults to STATIC.\n",
                    "long": "--nodev"
                }
            ]
        },
        "NOTES": {
            "content": "dhcpcd  requires  a  Berkeley  Packet  Filter, or BPF device on BSD based systems and a Linux\nSocket Filter, or LPF device on Linux based systems for all IPv4 configuration.\n\nIf restricting dhcpcd to a single interface and optionally address family  via  the  command-\nline then all further calls to dhcpcd to rebind, reconfigure or exit need to include the same\nrestrictive flags so that dhcpcd knows which process to signal.\n\nSome DHCP servers implement ClientID filtering.  If dhcpcd is replacing an in-use DHCP client\nthen  you might need to adjust the clientid option dhcpcd sends to match.  If using a DUID in\nplace of the ClientID, edit /var/lib/dhcpcd/duid accordingly.\n",
            "subsections": []
        },
        "FILES": {
            "content": "/etc/dhcpcd.conf\nConfiguration file for dhcpcd.  If you always use the same options, put them here.\n\n/usr/lib/dhcpcd/dhcpcd-run-hooks\nBourne shell script that is run to configure or de-configure an interface.\n\n/usr/lib/x8664-linux-gnu/dhcpcd/dev\nLinux /dev management modules.\n\n/usr/lib/dhcpcd/dhcpcd-hooks\nA directory containing Bourne shell scripts that are run by the above  script.   Each  script\ncan be disabled by using the -C, --nohook option described above.\n\n/var/lib/dhcpcd/duid\nText file that holds the DUID used to identify the host.\n\n/var/lib/dhcpcd/secret\nText file that holds a secret key known only to the host.\n\n/var/lib/dhcpcd/interface-ssid.lease\nThe  actual DHCP message sent by the server.  We use this when reading the last lease and use\nthe file's mtime as when it was issued.\n\n/var/lib/dhcpcd/interface-ssid.lease6\nThe actual DHCPv6 message sent by the server.  We use this when reading the  last  lease  and\nuse the file's mtime as when it was issued.\n\n/var/lib/dhcpcd/rdmmonotonic\nStores the monotonic counter used in the replay field in Authentication Options.\n\n/run/dhcpcd/pid\nStores the PID of dhcpcd running on all interfaces.\n\n/run/dhcpcd/interface.pid\nStores the PID of dhcpcd running on the interface.\n\n/run/dhcpcd/sock\nControl socket to the manager daemon.\n\n/run/dhcpcd/unpriv.sock\nUnprivileged socket to the manager daemon, only allows state retrieval.\n\n/run/dhcpcd/interface.sock\nControl socket to per interface daemon.\n\n/run/dhcpcd/interface.unpriv.sock\nUnprivileged socket to per interface daemon, only allows state retrieval.\n",
            "subsections": []
        },
        "SEE ALSO": {
            "content": "fnmatch(3),    ifnametoindex(3),    dhcpcd.conf(5),   resolv.conf(5),   dhcpcd-run-hooks(8),\nresolvconf(8)\n",
            "subsections": []
        },
        "STANDARDS": {
            "content": "RFC 951, RFC 1534, RFC 2104, RFC 2131,  RFC 2132,  RFC 2563,  RFC 2855,  RFC 3004,  RFC 3118,\nRFC 3203,  RFC 3315,  RFC 3361,  RFC 3633,  RFC 3396, RFC 3397, RFC 3442, RFC 3495, RFC 3925,\nRFC 3927, RFC 4039, RFC 4075, RFC 4242, RFC 4361,  RFC 4390,  RFC 4702,  RFC 4074,  RFC 4861,\nRFC 4833,  RFC 4941,  RFC 5227,  RFC 5942,  RFC 5969, RFC 6106, RFC 6334, RFC 6355, RFC 6603,\nRFC 6704, RFC 7217, RFC 7550, RFC 7844.\n",
            "subsections": []
        },
        "AUTHORS": {
            "content": "Roy Marples <roy@marples.name>\n",
            "subsections": []
        },
        "BUGS": {
            "content": "Please report them to https://roy.marples.name/projects/dhcpcd\n\nDebian                                      June 17, 2024                                  DHCPCD(8)",
            "subsections": []
        }
    },
    "summary": "dhcpcd — a DHCP client",
    "flags": [
        {
            "flag": "-b",
            "long": "--background",
            "arg": null,
            "description": "Background immediately. This is useful for startup scripts which don't disable link messages for carrier status."
        },
        {
            "flag": "-c",
            "long": "--script",
            "arg": null,
            "description": "Use this script instead of the default /usr/lib/dhcpcd/dhcpcd-run-hooks."
        },
        {
            "flag": "-D",
            "long": "--duid",
            "arg": null,
            "description": "Use a DHCP Unique Identifier. If a system UUID is available, that will be used to create a DUID-UUID, otherwise if persistent storage is available then a DUID-LLT (link local address + time) is generated, otherwise DUID-LL is generated (link local address). The DUID type can be hinted as an optional parameter if the file /var/lib/dhcpcd/duid does not exist. If not ll, lt or uuid then value will be con‐ verted from 00:11:22:33 format. This, plus the IAID will be used as the -I, --clientid. The DUID generated will be held in /var/lib/dhcpcd/duid and should not be copied to other hosts. This file also takes precedence over the above rules ex‐ cept for setting a value."
        },
        {
            "flag": "-d",
            "long": "--debug",
            "arg": null,
            "description": "Echo debug messages to the stderr and syslog."
        },
        {
            "flag": "-E",
            "long": "--lastlease",
            "arg": null,
            "description": "If dhcpcd cannot obtain a lease, then try to use the last lease acquired for the in‐ terface."
        },
        {
            "flag": "",
            "long": "--lastleaseextend",
            "arg": null,
            "description": "Same as the above, but the lease will be retained even if it expires. dhcpcd will give it up if any other host tries to claim it for their own via ARP. This violates RFC 2131, section 3.7, which states the lease should be dropped once it has expired."
        },
        {
            "flag": "-e",
            "long": "--env",
            "arg": null,
            "description": "Push value to the environment for use in dhcpcd-run-hooks(8). For example, you can force the hostname hook to always set the hostname with -e forcehostname=YES."
        },
        {
            "flag": "-g",
            "long": "--reconfigure",
            "arg": null,
            "description": "dhcpcd will re-apply IP address, routing and run dhcpcd-run-hooks(8) for each inter‐ face. This is useful so that a 3rd party such as PPP or VPN can change the routing table and / or DNS, etc and then instruct dhcpcd to put things back afterwards. dhcpcd does not read a new configuration when this happens - you should rebind if you need that functionality."
        },
        {
            "flag": "-F",
            "long": "--fqdn",
            "arg": null,
            "description": "Requests that the DHCP server update DNS using FQDN instead of just a hostname. Valid values for fqdn are disable, none, ptr and both. dhcpcd itself never does any DNS updates. dhcpcd encodes the FQDN hostname as specified in RFC 1035."
        },
        {
            "flag": "-f",
            "long": "--config",
            "arg": null,
            "description": "Specify a config to load instead of /etc/dhcpcd.conf. dhcpcd always processes the config file before any command line options."
        },
        {
            "flag": "-h",
            "long": "--hostname",
            "arg": null,
            "description": "Sends hostname to the DHCP server so it can be registered in DNS. If hostname is an empty string then the current system hostname is sent. If hostname is a FQDN (i.e., contains a .) then it will be encoded as such."
        },
        {
            "flag": "-I",
            "long": "--clientid",
            "arg": null,
            "description": "Send the clientid. If the string is of the format 01:02:03 then it is encoded as hex. For interfaces whose hardware address is longer than 8 bytes, or if the clientid is an empty string then dhcpcd sends a default clientid of the hardware fam‐ ily and the hardware address."
        },
        {
            "flag": "-i",
            "long": "--vendorclassid",
            "arg": null,
            "description": "Override the DHCPv4 vendorclassid field sent. The default is dhcpcd-<ver‐ sion>:<os>:<machine>:<platform>. For example dhcpcd-5.5.6:NetBSD-6.99.5:i386:i386 If not set then none is sent. Some badly configured DHCP servers reject unknown ven‐ dorclassids. To work around it, try and impersonate Windows by using the MSFT ven‐ dorclassid."
        },
        {
            "flag": "-j",
            "long": "--logfile",
            "arg": null,
            "description": "Writes to the specified logfile. dhcpcd still writes to syslog(3). The logfile is reopened when dhcpcd receives the SIGUSR2 signal."
        },
        {
            "flag": "-k",
            "long": "--release",
            "arg": null,
            "description": "This causes an existing dhcpcd process running on the interface to release its lease and de-configure the interface regardless of the -p, --persistent option. If no interface is specified then this applies to all interfaces in Manager mode. If no interfaces are left running, dhcpcd will exit."
        },
        {
            "flag": "-l",
            "long": "--leasetime",
            "arg": null,
            "description": "Request a lease time of seconds. -1 represents an infinite lease time. By default dhcpcd does not request any lease time and leaves it in the hands of the DHCP server."
        },
        {
            "flag": "-M",
            "long": "--manager",
            "arg": null,
            "description": "Start dhcpcd in Manager mode even if only one interface specified on the command line. See the Multiple Interfaces section above."
        },
        {
            "flag": "-m",
            "long": "--metric",
            "arg": null,
            "description": "Metrics are used to prefer an interface over another one, lowest wins. dhcpcd will supply a default metric of 1000 + ifnametoindex(3). This will be offset by 2000 for wireless interfaces, with additional offsets of 1000000 for IPv4LL and 2000000 for roaming interfaces."
        },
        {
            "flag": "-n",
            "long": "--rebind",
            "arg": null,
            "description": "Notifies dhcpcd to reload its configuration and rebind the specified interface. If no interface is specified then this applies to all interfaces in Manager mode. If dhcpcd is not running, then it starts up as normal."
        },
        {
            "flag": "-N",
            "long": "--renew",
            "arg": null,
            "description": "Notifies dhcpcd to renew existing addresses on the specified interface. If no interface is specified then this applies to all interfaces in Manager mode. If dhcpcd is not running, then it starts up as normal. Unlike the -n, --rebind option above, the configuration for dhcpcd is not reloaded."
        },
        {
            "flag": "-o",
            "long": "--option",
            "arg": null,
            "description": "Request the DHCP option variable for use in /usr/lib/dhcpcd/dhcpcd-run-hooks."
        },
        {
            "flag": "-p",
            "long": "--persistent",
            "arg": null,
            "description": "dhcpcd de-configures the interface when it exits unless this option is enabled. Sometimes, this isn't desirable if, for example, you have root mounted over NFS or SSH clients connect to this host and they need to be notified of the host shutting down. You can use this option to stop this from happening."
        },
        {
            "flag": "-r",
            "long": "--request",
            "arg": null,
            "description": "Request the address in the DHCP DISCOVER message. There is no guarantee this is the address the DHCP server will actually give. If no address is given then the first address currently assigned to the interface is used."
        },
        {
            "flag": "-s",
            "long": "--inform",
            "arg": null,
            "description": "Behaves like -r, --request as above, but sends a DHCP INFORM instead of DISCOVER/RE‐ QUEST. This does not get a lease as such, just notifies the DHCP server of the address in use. You should also include the optional cidr network number in case the address is not already configured on the interface. dhcpcd remains running and pre‐ tends it has an infinite lease. dhcpcd will not de-configure the interface when it exits. If dhcpcd fails to contact a DHCP server then it returns a failure instead of falling back on IPv4LL."
        },
        {
            "flag": "",
            "long": "--inform6",
            "arg": null,
            "description": "Performs a DHCPv6 Information Request. No address is requested or specified, but all other DHCPv6 options are allowed. This is normally performed automatically when the IPv6 Router Advertises that the client should perform this operation. This option is only needed when dhcpcd is not processing IPv6RA messages and the need for DHCPv6 In‐ formation Request exists."
        },
        {
            "flag": "-S",
            "long": "--static",
            "arg": null,
            "description": "Configures a static DHCP value. If you set ipaddress then dhcpcd will not attempt to obtain a lease and just use the value for the address with an infinite lease time. Here is an example which configures a static address, routes and DNS. dhcpcd -S ipaddress=192.168.0.10/24 \\ -S routers=192.168.0.1 \\ -S domainnameservers=192.168.0.1 \\ eth0 You cannot presently set static DHCPv6 values. Use the -e, --env option instead."
        },
        {
            "flag": "-t",
            "long": "--timeout",
            "arg": null,
            "description": "Timeout after seconds, instead of the default 30. A setting of 0 seconds causes dhcpcd to wait forever to get a lease. If dhcpcd is working on a single interface then dhcpcd will exit when a timeout occurs, otherwise dhcpcd will fork into the background."
        },
        {
            "flag": "-u",
            "long": "--userclass",
            "arg": null,
            "description": "Tags the DHCPv4 message with the userclass class. DHCP servers use this to give mem‐ bers of the class DHCP options other than the default, without having to know things like hardware address or hostname."
        },
        {
            "flag": "-v",
            "long": "--vendor",
            "arg": null,
            "description": "Add an encapsulated vendor option. code should be between 1 and 254 inclusive. To add a raw vendor string, omit code but keep the comma. Examples. Set the vendor option 01 with an IP address. dhcpcd -v 01,192.168.0.2 eth0 Set the vendor option 02 with a hex code. dhcpcd -v 02,01:02:03:04:05 eth0 Set the vendor option 03 with an IP address as a string. dhcpcd -v 03,\\\"192.168.0.2\\\" eth0 Set un-encapsulated vendor option to hello world. dhcpcd -v ,\"hello world\" eth0"
        },
        {
            "flag": "",
            "long": "--version",
            "arg": null,
            "description": "Display both program version and copyright information. dhcpcd then exits before do‐ ing any configuration."
        },
        {
            "flag": "-w",
            "long": null,
            "arg": null,
            "description": "an argument, unlike the below option. --waitip=[4 | 6] Wait for an address to be assigned before forking to the background. 4 means wait for an IPv4 address to be assigned. 6 means wait for an IPv6 address to be assigned. If no argument is given, dhcpcd will wait for any address protocol to be assigned. It is possible to wait for more than one address protocol and dhcpcd will only fork to the background when all waiting conditions are satisfied."
        },
        {
            "flag": "-x",
            "long": "--exit",
            "arg": null,
            "description": "This will signal an existing dhcpcd process running on the interface to exit. If no interface is specified, then the above is applied to all interfaces in Manager mode. See the -p, --persistent option to control configuration persistence on exit, which is enabled by default in dhcpcd.conf(5). dhcpcd then waits until this process has exited."
        },
        {
            "flag": "-y",
            "long": "--reboot",
            "arg": null,
            "description": "Allow reboot seconds before moving to the discover phase if we have an old lease to use. Allow reboot seconds before starting fallback states from the discover phase. IPv4LL is started when the first reboot timeout is reached. The default is 5 sec‐ onds. A setting of 0 seconds causes dhcpcd to skip the reboot phase and go straight into discover. This has no effect on DHCPv6 other than skipping the reboot phase."
        },
        {
            "flag": "-1",
            "long": "--oneshot",
            "arg": null,
            "description": "Exit after configuring an interface. Use the -w, --waitip option to specify which protocol(s) to configure before exiting."
        },
        {
            "flag": "-4",
            "long": "--ipv4only",
            "arg": null,
            "description": "Configure IPv4 only."
        },
        {
            "flag": "-6",
            "long": "--ipv6only",
            "arg": null,
            "description": "Configure IPv6 only."
        },
        {
            "flag": "-A",
            "long": "--noarp",
            "arg": null,
            "description": "Don't request or claim the address by ARP. This also disables IPv4LL."
        },
        {
            "flag": "-B",
            "long": "--nobackground",
            "arg": null,
            "description": "Don't run in the background when we acquire a lease. This is mainly useful for run‐ ning under the control of another process, such as a debugger or a network manager."
        },
        {
            "flag": "-C",
            "long": "--nohook",
            "arg": null,
            "description": "Don't run this hook script. Matches full name, or prefixed with 2 numbers optionally ending with .sh. So to stop dhcpcd from touching your DNS settings you would do:- dhcpcd -C resolv.conf eth0"
        },
        {
            "flag": "-G",
            "long": "--nogateway",
            "arg": null,
            "description": "Don't set any default routes."
        },
        {
            "flag": "-H",
            "long": "--xidhwaddr",
            "arg": null,
            "description": "Use the last four bytes of the hardware address as the DHCP xid instead of a randomly generated number."
        },
        {
            "flag": "-J",
            "long": "--broadcast",
            "arg": null,
            "description": "Instructs the DHCP server to broadcast replies back to the client. Normally this is only set for non-Ethernet interfaces, such as FireWire and InfiniBand. In most in‐ stances, dhcpcd will set this automatically."
        },
        {
            "flag": "-K",
            "long": "--nolink",
            "arg": null,
            "description": "Don't receive link messages for carrier status. You should only have to use this with buggy device drivers or running dhcpcd through a network manager."
        },
        {
            "flag": "-L",
            "long": "--noipv4ll",
            "arg": null,
            "description": "Don't use IPv4LL (aka APIPA, aka Bonjour, aka ZeroConf)."
        },
        {
            "flag": "-O",
            "long": "--nooption",
            "arg": null,
            "description": "Removes the option from the DHCP message before processing."
        },
        {
            "flag": "-P",
            "long": "--printpidfile",
            "arg": null,
            "description": "Print the pidfile dhcpcd will use based on command-line arguments to stdout."
        },
        {
            "flag": "-Q",
            "long": "--require",
            "arg": null,
            "description": "Requires the option to be present in all DHCP messages, otherwise the message is ig‐ nored. To enforce that dhcpcd only responds to DHCP servers and not BOOTP servers, you can -Q dhcpmessagetype."
        },
        {
            "flag": "-q",
            "long": "--quiet",
            "arg": null,
            "description": "Quiet dhcpcd on the command line, only warnings and errors will be displayed. If this option is used another time then all console output is disabled. These messages are still logged via syslog(3)."
        },
        {
            "flag": "-T",
            "long": "--test",
            "arg": null,
            "description": "On receipt of DHCP messages just call /usr/lib/dhcpcd/dhcpcd-run-hooks with the rea‐ son of TEST which echos the DHCP variables found in the message to the console. The interface configuration isn't touched and neither are any configuration files. The rapidcommit option is not sent in TEST mode so that the server does not lease an ad‐ dress. To test INFORM the interface needs to be configured with the desired address before starting dhcpcd."
        },
        {
            "flag": "-U",
            "long": "--dumplease",
            "arg": null,
            "description": "Dumps the current lease for the interface to stdout. If no interface is given then all interfaces are dumped. Use the -4 or -6 flags to specify an address family. If a lease is piped in via standard input then use the special interface named - to dump it. In this case, specifying an address family is mandatory."
        },
        {
            "flag": "-V",
            "long": "--variables",
            "arg": null,
            "description": "Display a list of option codes, the associated variable and encoding for use in dhcpcd-run-hooks(8). Variables are prefixed with new and old unless the option number is -. Variables without an option are part of the DHCP message and cannot be directly requested."
        },
        {
            "flag": "-W",
            "long": "--whitelist",
            "arg": null,
            "description": "Only accept packets from address[/cidr]. -X, --blacklist is ignored if -W, --whitelist is set."
        },
        {
            "flag": "-X",
            "long": "--blacklist",
            "arg": null,
            "description": "Ignore all packets from address[/cidr]."
        },
        {
            "flag": "-Z",
            "long": "--denyinterfaces",
            "arg": null,
            "description": "When discovering interfaces, the interface name must not match pattern which is a space or comma separated list of patterns passed to fnmatch(3)."
        },
        {
            "flag": "-z",
            "long": "--allowinterfaces",
            "arg": null,
            "description": "When discovering interfaces, the interface name must match pattern which is a space or comma separated list of patterns passed to fnmatch(3). If the same interface is matched in -Z, --denyinterfaces then it is still denied."
        },
        {
            "flag": "",
            "long": "--inactive",
            "arg": null,
            "description": "Don't start any interfaces other than those specified on the command line. This al‐ lows dhcpcd to be started in Manager mode and then wait for subsequent dhcpcd com‐ mands to start each interface as required."
        },
        {
            "flag": "",
            "long": "--configure",
            "arg": null,
            "description": "Allows dhcpcd to configure the system. This is the default behaviour and sets ifconfigured=true."
        },
        {
            "flag": "",
            "long": "--noconfigure",
            "arg": null,
            "description": "dhcpcd will not configure the system at all. This is only of use if the --script that dhcpcd calls at each network event configures the system instead. This is dif‐ ferent from -T, --test mode in that it's not one shot and the only change to the en‐ vironment is the addition of ifconfigured=false."
        },
        {
            "flag": "",
            "long": "--nodev",
            "arg": null,
            "description": "Don't load any /dev management modules. 3RDPARTY LINK MANAGEMENT Some interfaces require configuration by 3rd parties, such as PPP or VPN. When an interface configuration in dhcpcd is marked as STATIC or INFORM without an address then dhcpcd will monitor the interface until an address is added or removed from it and act accordingly. For point to point interfaces (like PPP), a default route to its destination is automatically added to the configuration. If the point to point interface is configured for INFORM, then dhcpcd unicasts INFORM to the destination, otherwise it defaults to STATIC."
        }
    ],
    "examples": [],
    "see_also": [
        {
            "name": "fnmatch",
            "section": "3",
            "url": "https://www.chedong.com/phpMan.php/man/fnmatch/3/json"
        },
        {
            "name": "ifnametoindex",
            "section": "3",
            "url": "https://www.chedong.com/phpMan.php/man/ifnametoindex/3/json"
        },
        {
            "name": "dhcpcd.conf",
            "section": "5",
            "url": "https://www.chedong.com/phpMan.php/man/dhcpcd.conf/5/json"
        },
        {
            "name": "resolv.conf",
            "section": "5",
            "url": "https://www.chedong.com/phpMan.php/man/resolv.conf/5/json"
        },
        {
            "name": "dhcpcd-run-hooks",
            "section": "8",
            "url": "https://www.chedong.com/phpMan.php/man/dhcpcd-run-hooks/8/json"
        },
        {
            "name": "resolvconf",
            "section": "8",
            "url": "https://www.chedong.com/phpMan.php/man/resolvconf/8/json"
        }
    ]
}